Fully Compatible with OS X Mavericks

We’re happy to report that┬áTumult Hype 2 and Tumult Hype 1.6.2 are fully compatible with Mac OS X Mavericks and Safari 7.

If you’re new to┬áTumult Hype, learn more here.

Screen Shot 2013-10-24 at 12.35.46 PM